Frequently Asked Questions (FAQ)

Q: What is the license?

A: The license is MIT Open Source.

Q: Which browsers are supported?

A: Flexify supports latest versions of modern browsers.

  • Latest Google Chrome
  • Latest Mozilla Firefox
  • Latest Opera
  • Latest Apple Safari
  • Internet Explorer 11+ and above

Q: What about old versions of Internet Explorer?

A: Microsoft does not support Internet Explorer 10 and below anymore. The percentage of old IE usage is about few percants and decresing. It does not worth it to maintain these browsers anymore.

Q: Why do I need to use if if there are Bootstrap/Foundation/Etc?

A: I was using Bootstrap for a long time and was pretty happy about it. But there are some thisng I missed in Bootstrap: support for flexbox, CSS dropdown menu which works on hover and not on click, etc. Every classname in Flexify is prefixed with [fx-] prefix for avoiding conflicts with other frameworks/libraries. You may use Flexify with another framework on the same project.

Q: Why Flexbox?

A: Flexbox provides simpler and more flexible layout options in CSS. More specifically, it provides:

  • Easy vertical alignment of content within a parent element.
  • Easy reordering of content across devices and screen resolutions with the help of media queries.
  • Easy CSS-only equal height columns for your grid-based layouts.
  • No need to clear floats.